Sync status is red, and the worker is unable to pull jobs into the mobile app

Overview

You have recently assigned one or more jobs to a worker. A few minutes later, the sync status goes red and the worker can no longer pull jobs into the mobile app.

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In the web interface, you see that the jobs are assigned to the worker, but not retrieved.

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Prerequisites

You must have an account with the one of the following roles:

  • Operations
  • Super User
  • Custom role with the rights to edit jobs.

Diagnosis

One or more jobs you assigned to the worker has at least one bad character. You can verify this by clicking a job > Edit Job Information

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See the screenshots below for examples of bad characters.
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These may be inadvertently copied and pasted from external sources while you were creating the job.

Solution

  1. Check all the properties of the job while editing it, such as Job Details and Job Location.
  2. Remove any bad characters you find based on the 2 example screenshots above.
  3. Do this for all the jobs you assigned to the worker.

<supportagent>

Reference tickets: 3670761, 3679298

</supportagent>

Testing

Once you have removed all the invalid characters from all the jobs assigned to the worker, ask them to sync the device again by tapping the sync icon

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The sync status should turn green and the worker should receive a notification in the app with the number of jobs pulled.

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The web interface will show that the jobs were retrieved.

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If the sync status is still red and new jobs are not pulled in the app, have the worker perform a clear activation.

 

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