Overview:
Mobile Workers are able to Start Shift, Stop Shift, and all the actions in the Mobile Application. They may also notice that the GPS coordinates were captured while working on the Application.
But, the GPS Coordinates are not captured in between these actions, like traveling.
Diagnosis:
It can be because of one of these issues:
- GPS on the device is switched off - This is possible cause if the GPS Coordinates are not at all captured.
- "Location Access" to the StreetSmart Application is configured as "Allow only while using the app".
- This is the most probable cause when the GPS Points are not recorded only during travel or when the phone is not actively being used.
Solution:
Based on the cause identified above:
- If GPS is Switched Off:
- Ensure that the Location Permissions for Street Smart App are set to "Allow All the time" / "Allow Always".
- For iPhone / iPad:
- Open iPhone Settings
- Scroll all the way to the bottom until you see "StreetSmart".
- Tap on it, a new screen will pop up, on it, you should ensure that:
- Location access is set to "Always".
- Background App Refresh is turned on.
- Cellular Data is turned on.
- Open iPhone Settings
- For Android:
- Open Settings.
- Find "Apps" and click on it.
- Scroll Down to Locate the "StreetSmart" App and click on it.
- Scroll Down and click on "Permissions".
- Click on "Location" Setting
- Set it to "Allow all the time".
- For iPhone / iPad:
- If this does not fix the issue, Perform a Clear Activation.
- Uninstall and Re-install the Application.
- Allow all Permissions requested by the Application.
- Once the app has been reinstalled, perform step 2.
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